Hướng dẫn cấu hình các thiết bị Cisco: Router, Switch, WIFI,...
trakimanhminh
một nămBình luận: 18
Mình chia sẻ cho với các bạn một số cách cấu hình thiết bị Cisco.

1. Cách cấu hình quay số pppoe cho Cisco Router

-> Cổng g0/0 kết nối với máy tính.
-> Cổng g0/1 kết nối modem VNPT
-> VD: Tên đường truyền là aaaa, password là bbbb
-> Cấu hình Router như sau:

Quảng cáo


router> en
Nhập password nếu có
router# conf t

* Bắt đầu cấu hình port kết nối với Modem VNPT *

router(config)# interface g0/1
router(config-if)# description $VNPT$
router(config-if)# no ip address
router(config-if)# ip tcp adjust-mss 1400
router(config-if)# pppoe en group global
router(config-if)# pppoe-client dial-pool-number 1
router(config-if)# no shut
router(config-if)# no cdp enable
router(config-if)# duplex auto
router(config-if)# speed auto

Quảng cáo


router(config-if)# exit

* Bắt đầu quay số pppoe *

router(config)# int dialer 1
router(config-if)# ip add nego
router(config-if)# ip mtu 1454
router(config-if)# ip nat outside
router(config-if)# ip nat enable
router(config-if)# ip tcp adjust-mss 1400
router(config-if)# encapsulation ppp
router(config-if)# dialer pool 1

Quảng cáo


router(config-if)# dialer-group 1
router(config-if)# no cdp en
router(config-if)# ppp authentication pap chap callin
router(config-if)# ppp pap sent-username aaaa password 0 bbbb
router(config-if)# ppp chap hostname aaaa
router(config-if)# ppp chap password bbbb
router(config-if)# exit

* Bắt đầu cấu hình port kết nối LAN *

router(config)#int g0/0
router(config-if)# ip add 192.168.1.1 255.255.255.0
router(config-if)# no shut
router(config-if)# ip nat inside
router(config-if)# ip nat enable
router(config-if)# ip tcp adjust-mss 1400
router(config-if)# ip virtual-reassembly
router(config-if)# duplex auto
router(config-if)# speed auto
router(config-if)# exit

* Cấu hình định tuyến, để các IP bên ngoài có thể đi vào router thông qua dialer 1 *

router(config)# ip route 0.0.0.0 0.0.0.0 dialer 1

* Tạo danh sách IP bên trong LAN được phép kết nối ra internet *

router(config)# access-list 1 permit 192.168.1.0 0.0.0.255

* Cấu hình NAT theo access-list đã cấu hình phía trên *

router(config)# ip nat inside source list 1 interface dialer 1 overload

* Tạo pool DHCP để cấp IP cho các máy bên trong mạng LAN *

router(config)# service dhcp
router(config)# ip dhcp pool 1
router(config-if)# network 192.168.1.0 255.255.255.0
router(config-if)# default-router 192.168.1.1
router(config-if)# dns-server 8.8.8.8
router(config-if)# exit

* Tạo dải IP loại trừ để phòng trường hợp cần set IP tĩnh *

router(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.20
router(config)
#exit

* Lưu toàn bộ cấu hình *

router# wr

* Lưu ý *
1. Đối với mạng VNPT, cần tắt modem nhà mạng tầm 20-30s, sau đó mở lại.
2. Đối với mạng FPT, cần gọi lên tổng đài để xác thực MAC-Address
3. Đối với mạng Viettel, lúc trước cần phải tag VLAN 35, nhưng sau này họ đã bỏ tag, nên trước khi cấu hình, cần phải hỏi rõ để cấu hình cho chính xác.
[/quote]

***** Video hướng dẫn *****


2. Cấu hình quay số pppoe Viettel tag VLAN 35:

* Sơ đồ *

G0/0: Kết nối với VIETTEL, tag VLAN 35 để quay số pppoe
G0/1: Kết nối với SWITCH hoặc LAPTOP, PC
Bạn cấu hình như sau:

---> Cấu hình port g0/1 <---

router# conf t
router(config)# int g0/1
router(config-if)# description $LOCAL_LAN$
router(config-if)# ip add 192.168.1.1 255.255.255.0
router(config-if)# no shut
router(config-if)# ip nat inside
router(config-if)# ip nat enable
router(config-if)# ip tcp adjust-mss 1400
router(config-if)# ip virtual-reassembly in
router(config-if)# duplex auto
router(config-if)# speed auto
router(config-if)# exit

---> Cấu hình port G0/0 và tag vlan 35 <---

router(config)# interface g0/0
router(config-if)# no shutdown
router(config-if)# exit
router(config-if)# interface g0/0.35
router(config-if)# description $VIETTEL_1$
router(config-if)# encapsulation dot1q 35
router(config-if)# no ip address
router(config-if)# ip tcp adjust-mss 1400
router(config-if)# pppoe en group global
router(config-if)# pppoe-client dial-pool-number 1
router(config-if)# no shut
router(config-if)# no cdp enable
router(config-if)# exit

---> Tiến hành quay số pppoe <---

router(config)# int dialer 1
router(config-if)# ip add nego
router(config-if)# ip mtu 1454
router(config-if)# ip nat outside
router(config-if)# ip nat enable
router(config-if)# ip tcp adjust-mss 1400
router(config-if)# encapsulation ppp
router(config-if)# dialer pool 1
router(config-if)# dialer-group 1
router(config-if)# no cdp en
router(config-if)# ppp authentication pap chap callin
router(config-if)# ppp pap sent-username aaaa password 0 bbbb
router(config-if)# ppp chap hostname aaaa
router(config-if)# ppp chap password bbbb
router(config-if)# exit

---> Tiến hành route, NAT, cấu hình access-list, pool DHCP <---

router(config)# ip route 0.0.0.0 0.0.0.0 dialer 1
router(config)# access-list 1 permit 192.168.1.0 0.0.0.255
router(config)# ip nat inside source list 1 interface dialer 1 overload
router(config)# service dhcp
router(config)# ip dhcp pool 1
router(config-if)# network 192.168.1.0 255.255.255.0
router(config-if)# default-router 192.168.1.1
router(config-if)# dns-server 8.8.8.8
router(config-if)# exit

---> Tạo dải IP loại trừ và lưu cấu hình <---

router(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.20
router(config)
#exit
router# wr


3. Cách reset router Cisco:



4. Cách reset router khi vướng "PASSWORD RECOVERY FUNCTIONALITY IS DISABLED" :


5. Hướng dẫn khôi phục và copy IOS vào flash trên Cisco router trong chế độ ROMMON bằng TFTP:

18 bình luận
Cám ơn bác đã chia sẽ
**** Hướng dẫn tag VLAN 35 quay số pppoe Viettel cho Linksys WRT32X ****



**** Hướng dẫn quay số pppoe và cài đặt phát wifi cho Linksys WRT32X ****



**** Hướng dẫn cài đặt phát wifi cho Linksys WRT32X ****



**** Hướng dẫn tag VLAN 35 quay số pppoe Viettel cho Linksys WRT1900AC / WRT 1900AC V2 / WRT 1900 ACS ****



*** Hướng dẫn cài đặt phát wifi cho Linksys WRT1900AC / WRT 1900AC V2 / WRT 1900 ACS ***

Cái này dùng phổ thông ít ai sài.
@hoangheo121014 Cái này sử dụng cho các công ty vừa và nhỏ chạy ổn định 😃 Kinh phí đầu tư cũng không quá cao. Đừng ham mua những thiết bị mới nhất là được rồi bạn.

Với kinh phí tầm 5 triệu, là đã có 1 bộ thiết bị bao gồm router và wifi chạy ổn định cho đường truyền 160Mbs rồi 😃
Làm một bài hướng dẫn router cisco cân bằng tải Nat 2 wan đi bác.
@backsimon88 Có luôn bạn, để từ từ mình sẽ up lên luôn 😃
@trakimanhminh Mình bị bí chổ Nat table khi chuyển wan, sử dụng even để clear, nhưng thấy sao sao ấy. Ko hay
@backsimon88 Thằng Cisco nó bị bựa ở chỗ đó, do chưa hỗ trợ ip động next-hop trong route-map, nên mới phải sử dụng EEM Script.
Nếu bạn sử dụng IP WAN tĩnh có lẽ sẽ không cần sử dụng EEM Script 😃
@trakimanhminh Nên nói thật sự nên sử dụng những thằng chuyên link load balace để care mấy vụ cân bằng tải wan như vậy, sài đồ ko đúng chức năng của nó thiệt mệch não.
cái này hay nè...
anh em chuyên mạng vào vọc vạch nào
GUI còn chít lên chít xuống nữa là Command
@hainhumai Lúc quen command rồi thì bác chẳng muốn sài gui đâu, đa phần gần như có những cái gui ko có sẵn để cấu hình, nhưng command thì làm được.
@hainhumai Cisco cấu hình Command phần lớn bạn ơi 😁
Xin hướng dẫn config thành access point cho cisco ap 18311 s k9 .
@Bùi Hoài Bắc Đây nhé bạn:

@Bùi Hoài Bắc Hướng dẫn thêm Cisco Access Point vào Mobility Express

Cách reset router Cisco bằng console



- Cách này có thể áp dụng đối với các router thông thường của Cisco.
- Trong ROMMON không hỗ trợ chế độ tab, nên chúng ta phải gõ hết câu lệnh - Chú ý gõ đúng câu lệnh, nếu gõ sai thì router sẽ báo lỗi.
- Đối với trường hợp router đã cấu hình "no service password-recovery" và "no service password-recovery strict" sẽ có cách reset router khác.










  • Chịu trách nhiệm nội dung: Trần Mạnh Hiệp
  • © 2023 Công ty Cổ phần MXH Tinh Tế
  • Địa chỉ: Số 70 Bà Huyện Thanh Quan, P. Võ Thị Sáu, Quận 3, TPHCM
  • Số điện thoại: 02862713156
  • MST: 0313255119
  • Giấy phép thiết lập MXH số 11/GP-BTTTT, Ký ngày: 08/01/2019